PHP is among the most widely used coding languages. It is quite popular since it is free software, which you can use to set up interactive websites such as social networks, shopping portals or e-learning sites as opposed to static HTML websites. A PHP module should be available on the server where a PHP-driven website is hosted so that its PHP code can be interpreted. Because there are no license charges for this type of module and the language itself offers endless possibilities for the web-based applications that you create, there’re 100s of millions of PHP sites. Furthermore, there’re a ton of open-source PHP-based scripts, which you can use for your sites without the need to have any coding expertise. Considering the fact that there are a handful of PHP versions, you should confirm if the very same version that you used while building your site is available on the server too.

PHP 4 and PHP 5 Support in Cloud Website Hosting

With our cloud website hosting plans, you will be able to choose the version of PHP that will be enabled for your web hosting account, as multiple versions are activated on our servers. With only one mouse click, you’ll be able to switch between PHP 5.5, 5.4, 5.3, 5.2 and 4 and anytime a new version is launched in the future, we’ll add it to the Hepsia Control Panel without removing the earlier versions. In this way, you will be able to host all the websites that you’ve set up throughout the years. In stark contrast to a lot of other companies, we will not force you to update such sites, because a script may be outdated, but this does not automatically mean that it’s vulnerable as you may have implemented modifications to its source code to fix safety holes. For your convenience, you’ll even be able to choose a different PHP version for each website hosted in your shared account.

PHP 4 and PHP 5 Support in Semi-dedicated Servers

Even if your sites were built with an earlier PHP version, you’ll be able to host them in a semi-dedicated server account from us, since we support different versions running simultaneously on our semi-dedicated servers and each one of them can be enabled for your account with just one click via our custom-built Hepsia Control Panel. Besides the newest PHP 5.4 and PHP 5.5, we also offer support for 5.3, 5.2 and the older PHP 4, which has already been dropped by the great majority of hosting companies, but we strongly maintain that you should not be compelled to modify a site that took years to set up, since older programming language syntax does not automatically imply safety flaws. Just the opposite, a well-maintained website using PHP 4 can be more reliable than an unmaintained one using PHP 5. For your convenience, we’ll also give you the possibility to set a different version for each individual website within your account.